BVE version v FPS

View previous topic View next topic Go down

BVE version v FPS

Post by RWremote on Sat Jan 18, 2014 2:46 pm

I'm having real trouble getting any version of BVE above 1.4.0.10 to run with any decent FPS.

I have two rigs both with XP SP3
- Athlon x2 250 3GHz 3G ram on board graphics which I use for my programming/email/web browsing etc/ this runs 1.4.0.10 at 36fps, 1.4.2 at 7 fps and 1.4.3 at 0 fps
- Intel i5, 3.1GHz 3G ram Radeon 7850 graphics card, used for FS games (FS2004, FSX & X-Plane) runs 1.4.0.10 at 65fps, 1.4.2 at 13fps and 1.4.3 at 9fps.

I've looked at odakyufan's changelog and the differences (on the performance side), are mostly to do with anti-aliasing. I've tried all the anti-aliasing settings even switching them off but the rates are still pretty much as above.
What was the main difference between 1.4.0 and 1.4.2/3 ?
Is this likely to be GPU or CPU related ?

Cheers for any ideas . . . .
avatar
RWremote

Posts : 9
Join date : 2011-08-07
Location : Southern U.K.

Back to top Go down

Re: BVE version v FPS

Post by HijauKuda on Sat Jan 18, 2014 4:14 pm

Sir RWremote
I do have better good luck of FPS in the openBVE when I do configuration this

openBVE\Settings\Options.Cfg

[display]
vsync = false
loadInAdvance = true

[quality]
interpolation = anisotropicFiltering
anisotropicFilteringLevel = 8
anisotropicFilteringMaximum = 16
antiAliasingLevel = 2
transparencyMode = 1
viewingDistance = 900
motionBlur = low


I greatly hope this is of usefulness for you.
Good day and night for you.
HK

HijauKuda

Posts : 74
Join date : 2012-01-18

Back to top Go down

Re: BVE version v FPS

Post by Dexter on Sat Jan 18, 2014 6:32 pm

I will take a look into that... I am still using 1.4.2, since I do not appreciate the omited cylinder basis to be rendered. Firstly, some of them are omited on purpose, secondly, those faces are very complex and thus lowering fps. I will test it on Monday.
avatar
Dexter

Posts : 1842
Join date : 2011-07-08
Age : 31
Location : Brno, Czech republic

http://www.brnobve.eu

Back to top Go down

Re: BVE version v FPS

Post by call2 on Sat Jan 18, 2014 11:24 pm

I take it that you have .Net 4.0 installed?

call2

Posts : 37
Join date : 2011-08-31

Back to top Go down

Re: BVE version v FPS

Post by Dexter on Sun Jan 19, 2014 3:44 pm

I do have .NET 4.5. Basically speaking, the fps really seems to be lowering towards newer versions... not sure shy, though.
avatar
Dexter

Posts : 1842
Join date : 2011-07-08
Age : 31
Location : Brno, Czech republic

http://www.brnobve.eu

Back to top Go down

Re: BVE version v FPS

Post by call2 on Sun Jan 19, 2014 6:18 pm

I'm no Microsoft guru, but I know that OpenBve was compiled using .Net4.0 and 4.5 wasn't out at the time. I don't know if the two versions are that different, but as they will both co-exist on Windows, it might be worth downloading .Net4.0. to see if it improves matters.

I'll learn something too! Wink

call2

Posts : 37
Join date : 2011-08-31

Back to top Go down

Re: BVE version v FPS

Post by Dexter on Sun Jan 19, 2014 9:46 pm

So, I have done a few tests and here is what I have come up with.

CPU: AMD Phenom II x4 @ 3.0 GHz
RAM: Kingston HyperX Blu 4GB @ 1600 MHz
GPU: HP Radeon 8760HD, Core @ 1GHz, 2GB DDR5 @ 4500 MHz
OS: Win 7, 64-bit, Ultimate

Not a bad PC, ridiculous results, though. Same route, same place, same settings.

OpenBVE       fps
1.2.12.10 --- 16.9 fps
1.4.1       --- 16.7 fps
1.4.3       --- 15.0 fps (AntiAliasing = 0)
1.4.3       --- 15.0 fps (AntiAliasing = 16)

So something is not right here... scratch  Evil or Very Mad
Especially version 1.4.3 gives me rubbish performance. I can play FIFA14 at FullHD with Supersampling enabled at full detail...
avatar
Dexter

Posts : 1842
Join date : 2011-07-08
Age : 31
Location : Brno, Czech republic

http://www.brnobve.eu

Back to top Go down

Re: BVE version v FPS

Post by Quork on Sun Jan 19, 2014 10:35 pm

The crux is in your OS - OpenBVE isn't optimised for 64-bit systems AFAIK. But I think I already said this once. Same goes for call2's suggestion of installing .NET 4.0 additionally, which you back than planned on doing?
avatar
Quork

Posts : 1098
Join date : 2012-05-05
Age : 26
Location : Hofheim a.T., Hessen (Hesse), European Union

Back to top Go down

Re: BVE version v FPS

Post by RWremote on Fri Jan 24, 2014 12:06 am

Thanks a lot HijauKuda, I made those changes and things have improved.

The PC with the dedicated Graphics card now gets 22fps on 1.4.2 and 1.4.3 which is a great improvement and OpenBVE is now playable using the latest version.
(Still have a big jump between 1.4.0 and 1.4.2 though. . . . . )
The PC with on-board graphics did not improve much, but I think that is to be expected.

Thanks again to everyone who replied.
avatar
RWremote

Posts : 9
Join date : 2011-08-07
Location : Southern U.K.

Back to top Go down

Re: BVE version v FPS

Post by HijauKuda on Fri Jan 24, 2014 1:25 pm

Sir RWremote
Good news for you. I do believe this setting configuration of most importance
loadInAdvance = true

Good day and night for you
HK

HijauKuda

Posts : 74
Join date : 2012-01-18

Back to top Go down

Re: BVE version v FPS

Post by buckysam on Fri Jan 24, 2014 8:28 pm

Quork wrote:The crux is in your OS - OpenBVE isn't optimised for 64-bit systems AFAIK. But I think I already said this once. Same goes for call2's suggestion of installing .NET 4.0 additionally, which you back than planned on doing?
That's strange.  scratch I have Windows 7 Home Premium 64-bit, and I don't ever recall having any problems running the program and I have all settings on medium-high to high, with antianalising at 16. It varies between 30ish to 60 fps and the lowest I can recall is probably in the 20ish range. I'll have to check on that, though.

buckysam

Posts : 150
Join date : 2012-05-28
Age : 21
Location : Kentucky USA

Back to top Go down

Re: BVE version v FPS

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum