Teleported to rear cab?!

View previous topic View next topic Go down

Teleported to rear cab?!

Post by jsiren on Wed Jan 08, 2014 5:34 pm

Hi all,

I've been busy for a few months, but have recently gotten back to OpenBVE. I was running the NWM 2001 HST route (12.00 1A34 HST Express Maybank-Hammerwich via Mainline) with the trainsimcentral HST set. I've run it previously (quite recently as well, the same combination and versions) without a glitch, but this time something truly bizarre happened.

The screen stalled for a long time, perhaps 10 to 15 seconds. Engine sound continued to play, but the simulation was otherwise completely unresponsive. I tried pressing the emergency stop button (mapped to the joystick), but got no response. After a while, the screen came back to life, and I found the driver mysteriously teleported to the rear cab!  Shocked Yes, rear cab, as the train appeared to be on the right track, and applying power with the direction set forward caused the train to move backward from the driver's point of view. The controls, however, were active, and henceforth worked as usual, but as you can imagine, it's somewhat difficult to drive from the rear cab...

I don't think I did anything special, as I was just accelerating at full throttle toward 125 mph. This happened between Cottenham and Nuthurst just before the neutral section. I couldn't repeat the events. Unfortunately black box wasn't in use.

What on earth could have happened? OpenBVE version is 1.4.0.9 on Ubuntu 12.04 LTS 64-bit.

jsiren

Posts : 106
Join date : 2012-09-16

Back to top Go down

Re: Teleported to rear cab?!

Post by Stevegr on Wed Jan 08, 2014 8:49 pm

Most odd.

No trains are configured with rear cabs.

You seem to have found a element of Open Bve I personally know nothing about.

Could anyone one else explain it?

I am quite worried as all my releases are based on TSC work, so should behave in the same way and any other releases by other developers are basically the same.

But I don't have a clue why or even how for that matter that occurs.

Rather interesting. 

I note from you previous posts you seem to have a lot of things going wrong with your running of Open Bve that most people do not.

Why is that, well I can't explain it at all.

Most odd.
avatar
Stevegr

Posts : 135
Join date : 2013-01-01
Location : CARDIFF

https://sites.google.com/a/bve4trains.com/bve4trains/

Back to top Go down

Re: Teleported to rear cab?!

Post by jsiren on Wed Jan 08, 2014 9:02 pm

My theory is that some glitch simply flipped the trainset around (180 degrees). Seems that both OpenBVE and NWM have been updated, so I'll try running the updated versions from now on.

I've been running the Ubuntu repository version on and off, maybe it's been compiled with weird options?

jsiren

Posts : 106
Join date : 2012-09-16

Back to top Go down

Re: Teleported to rear cab?!

Post by thehoviskid on Wed Jan 08, 2014 9:05 pm

Actually, it's always been like that so don't panic.  Nothing to do with NWM either.  CTRL+R to unrestrict the view and unlike BVE4 you can zoom out beyone, and move outside the limits of the panel image that forms the background to the cab.  If you rotate 180 degrees, you get the panel looking backwards.

Go on, try it!

It's not truly a rear cab though as it's still up at the front of the train (if you're in a platform awaiting departure and you "turn round" you 're still up by the signal) and in a left-hand-drive cab the view point is configured to be more or less above the left hand rail- "turn around" and you'll notice you're above the same rail (now the right hand one in the direction you're now looking) and so half of your cab is hanging over the adjacent line.

Press Ctrl+R again and it re-restricts you again.

I think the unrestricted view was built-in in anticipation of 3D cabs, where you really can look out the side window.

It was mentioned once on the old O-BVE forum as a bug, but the answer was that it wasn't really a bug as it was semi intentional so "meh", BVE4 behaved differently because nothing outside the cab existed and you could never move outside the panel image- you could zoom out and pan around it, but no more.
avatar
thehoviskid

Posts : 135
Join date : 2011-07-09
Age : 40
Location : Heysham

Back to top Go down

Re: Teleported to rear cab?!

Post by jsiren on Wed Jan 08, 2014 9:16 pm

Ah, thanks for the explanation! Now I know how to recover if this happens again. Thing is, I didn't press Ctrl-R! Like I said, I was just driving along the track at full throttle (joystick), didn't touch the keyboard at all. I haven't mapped CAMERA_RESTRICTION to any joystick buttons... confused

jsiren

Posts : 106
Join date : 2012-09-16

Back to top Go down

Re: Teleported to rear cab?!

Post by jsiren on Mon Jul 14, 2014 7:48 pm

Getting back to this old thing, my hard drive may have been getting read errors at the time causing random freezes, which might account for the erratic behaviour.

jsiren

Posts : 106
Join date : 2012-09-16

Back to top Go down

Re: Teleported to rear cab?!

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum