Need Helpers with "AutoHotKey"

View previous topic View next topic Go down

Need Helpers with "AutoHotKey"

Post by CaptED on Mon Oct 22, 2012 8:39 pm

Hi to all Readers...

I am using OpenBVE 1.4.2 and am a Newbie...

As most of you know there is a issue with using Throttle in Joystick Full Axis... (Does NOT Work)
Half Axis YES Full Axis NO.....

So my thinking is trying something like AutoHotKey... and have the Joystick... Send a Key Press to OpenBVE...

Now I want a Specific action of the Joystick Axis...

I want the Joystick to start with throttle at Zero and as I increase the Axis it would press the "A" key and as I increase the movement
it would press the A key again (working much like Notches)
and if I reduced the Axis it would press the "Z" key..

Now I do have a working Script but not working like I want ... I am having to leave the Axis Handle at 50% and increase works but hold the key down..
which is not what I want....

While I am using a Saitek Throttle Quad (3 Axis model) I only need this to work with one axis...

** Side Note **
You are asking why does this Guy want a Axis to work.. Simple all Trains are modeled with moving Levers... and I want to control the train with levers...
If this could be solved ... It could also help your friends that have Train Simulator 2012/2013... None of the Train Sim's have default Joystick controllers ...
Train Sim 2013 has gone to a Xbox 360 controller (GamePad)... NO JOYSTICK ...

I do accept Hints ... copy paste of the Script etc... and YES I have read the Manual the parts I could understand that is ...

Thanks in Advance
Ed
avatar
CaptED

Posts : 59
Join date : 2012-08-19
Age : 73
Location : Bryant, Arkansas

Back to top Go down

Re: Need Helpers with "AutoHotKey"

Post by Dexter on Wed Oct 24, 2012 8:16 am

To be honest, I am only using gamepad... so I am a bit of no use here...
avatar
Dexter

Posts : 1842
Join date : 2011-07-08
Age : 31
Location : Brno, Czech republic

http://www.brnobve.eu

Back to top Go down

Re: Need Helpers with "AutoHotKey"

Post by ecreek on Thu Oct 25, 2012 2:11 am

What exactly is the problem with using Throttle in Joystick Full Axis? I have a home built controller with one full axis for throttle and another for brake and it works fine.

ecreek

Posts : 32
Join date : 2011-08-23

Back to top Go down

Re: Need Helpers with "AutoHotKey"

Post by CaptED on Thu Oct 25, 2012 5:41 pm

Hi "ecreek" and other Readers....

I would be extremely interested in how you managed to get "Throttle Full Axis" working...

Here is my issue... When I setup the Joystick Axis to work with the Throttle Full axis I actally only get 50% movement ... What I mean is when I slide the Handle forward it goes pass the half way mark before applying any throttle...

Now I test this with Trains that use Two handle (one Throttle one Brake)
Trains I am using come from "graymac" and I did test both 079 Timber Train and 218 Container Train...
(If You don't have these you owe it to yourself to download ever thing he has ...)

Now the Brake Full Axis and the Throttle/Brake both work as they are suppose to ...

Considering you are the first to reply that actually uses a Joystick to control a train I would appreciate a detail setup only for the Throttle ..
and if you want to tell about your home made controller it sounds interesting...

If I need to give a detail setup of Throttle lever I will do so with Pictures...

Thanks
Ed
avatar
CaptED

Posts : 59
Join date : 2012-08-19
Age : 73
Location : Bryant, Arkansas

Back to top Go down

Re: Need Helpers with "AutoHotKey"

Post by ecreek on Fri Oct 26, 2012 5:39 am

Hi Ed,
I think you are right. When configuring the joystick or controller in the OpenBVE screen it shows movement of the throttle over the full range but in the game it does not 'kick in' until it reaches half way. I hadn't paid much attention to this before since my throttle control only moves through about 60 degrees.
Do you remember where you read about it being a problem?

Michael

ecreek

Posts : 32
Join date : 2011-08-23

Back to top Go down

Re: Need Helpers with "AutoHotKey"

Post by CaptED on Fri Oct 26, 2012 8:25 pm

Hi Michael "ecreek"

I am the one that found the "Full Throttle Axis" Bug ..

If you look at the Post by me about this Subject, mostly in the Newbie section...

Turns out there is no one doing any development work on OpenBVE...

So we are stuck with the problem until we find a work around...

You are actually the only person that has replied that uses a Joystick...

Again Thanks for atleast checking your joystick...

Ed


avatar
CaptED

Posts : 59
Join date : 2012-08-19
Age : 73
Location : Bryant, Arkansas

Back to top Go down

Re: Need Helpers with "AutoHotKey"

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum