Linux-ObjectViewer crashes

Go down

Linux-ObjectViewer crashes

Post by liquid_ on Fri Aug 31, 2012 9:00 pm

Linux 12.04 64b.
Any OpenBVE program executes on my system but ObjectViewer. It crashes. The output is as follows:

desktop:~/BVE$ cli ObjectViewer.exe

at (wrapper managed-to-native) Tao.Sdl.Sdl.SDL_MapRGB (intptr,byte,byte,byte) <0xffffffff>
at OpenBve.Program.Main (string[]) <0x0068f>
at (wrapper runtime-invoke) .runtime_invoke_void_object (object,intptr,intptr,intptr) <0xffffffff>

Native stacktrace:

cli() [0x4916ba]
cli() [0x4e0d4f]
cli() [0x41bc77]
/lib/x86_64-linux-gnu/ [0x7fc1f84b3cb0]
/usr/lib/x86_64-linux-gnu/ [0x7fc1f518c953]

Debug info from gdb:

Could not attach to process. If your uid matches the uid of the target
process, check the setting of /proc/sys/kernel/yama/ptrace_scope, or try
again as the root user. For more details, see /etc/sysctl.d/10-ptrace.conf
ptrace: Operation not permitted.
No threads.

Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.

Aborted (core dumped)

The same happens when started with mono.
Could somebody help me on it? I would appreciate.


Posts : 26
Join date : 2012-05-15

Back to top Go down

Re: Linux-ObjectViewer crashes

Post by alvinhochun on Thu Sep 06, 2012 11:48 am

I guess `cli` is just a symlink of `mono`.

What's the version of Mono are you having?

By the way openBVE uses Tao.Framework which hasn't been updated for too long. I think someone will have to port it to OpenTK (although it's just replacing a reference and changing some `using` directives)

Posts : 88
Join date : 2012-05-08
Location : Hong Kong

Back to top Go down

Back to top

Permissions in this forum:
You cannot reply to topics in this forum