Frequent BSODs while playing OpenBVE

View previous topic View next topic Go down

solved Frequent BSODs while playing OpenBVE

Post by Damian John Wit on Mon Jun 11, 2012 12:29 pm

I believe this question was asked before in the OpenBVE official forums, but unfortunately, it is closed now.

Anyway, since the last few days after a few seconds of playing OpenBVE a BSOD appears (once when I was going at 100 kph and once when I put a lot of horn or sometimes after crossing 100m/diverging tracks) and the sound gets stuck and I have to manually restart it. (sometimes it restarts itself). And I recently had repaired the PC as it had a motherboard failure. (the game was working before the failure)

What could be the cause of this? Hardware acceleration?
I believe I set it to FULL for the sound...
And I also updated my display driver Intel 945GM to the latest version for my XP SP3.
My laptop is a 120 GB HDD Fujitsu A6025 (2007ver)

Any help would be appreciated.

NOTE: Route Viewer works fine without issues.


Last edited by Northern Line on Fri Jul 27, 2012 8:35 pm; edited 3 times in total (Reason for editing : Solved)

Damian John Wit

Posts : 39
Join date : 2012-05-09
Age : 32
Location : Sydney

Back to top Go down

solved Re: Frequent BSODs while playing OpenBVE

Post by Quork on Mon Jun 11, 2012 3:03 pm

Try with no hardware acceleration at all?
avatar
Quork

Posts : 1098
Join date : 2012-05-05
Age : 26
Location : Hofheim a.T., Hessen (Hesse), European Union

Back to top Go down

solved Re: Frequent BSODs while playing OpenBVE

Post by alvinhochun on Tue Jun 12, 2012 2:56 am

First try disabling sound in openBVE and see if it still happens. If not, then probably the problem of sound.
avatar
alvinhochun

Posts : 88
Join date : 2012-05-08
Location : Hong Kong

Back to top Go down

solved Re: Frequent BSODs while playing OpenBVE

Post by Wulf_9 on Tue Jun 12, 2012 3:12 pm

A likely culprit is your video driver - make sure it's up to date...

*Edit* Just noticed you have an Intel 945 - buy a better GFX card maybe? Cool
avatar
Wulf_9

Posts : 33
Join date : 2012-05-09
Age : 58
Location : Norwich UK

Back to top Go down

solved Re: Frequent BSODs while playing OpenBVE

Post by Damian John Wit on Fri Jun 15, 2012 4:53 pm

Thanks everyone for the feedback and suggestion.

The problem is almost fixed now, and the likely culprit was the hardware acceleration, and as soon as I set it to NONE, results are looking encouraging and optimistic (trying out different settings where it BSODed)

Damian John Wit

Posts : 39
Join date : 2012-05-09
Age : 32
Location : Sydney

Back to top Go down

solved Re: Frequent BSODs while playing OpenBVE

Post by Dexter on Fri Jun 15, 2012 5:49 pm

How about the sound driver? Checked that one then?
avatar
Dexter

Posts : 1842
Join date : 2011-07-08
Age : 31
Location : Brno, Czech republic

http://www.brnobve.eu

Back to top Go down

solved Re: Frequent BSODs while playing OpenBVE

Post by Damian John Wit on Fri Jul 27, 2012 4:23 pm

Yep, it works great :-)

After 2 months or so, I have upgraded from XP SP3 to Windows 7 Ultimate SP1. Very Happy

Only low frame rate is the issue otherwise (9.8~11)

Damian John Wit

Posts : 39
Join date : 2012-05-09
Age : 32
Location : Sydney

Back to top Go down

solved Re: Frequent BSODs while playing OpenBVE

Post by Northern Line on Fri Jul 27, 2012 8:35 pm

I did the same, just I need more ram.
avatar
Northern Line

Posts : 281
Join date : 2011-07-12
Age : 24
Location : Tooting, London, England

http://www.bve-district.co.uk/

Back to top Go down

solved Re: Frequent BSODs while playing OpenBVE

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum