OpenBVE signal problem

View previous topic View next topic Go down

OpenBVE signal problem

Post by briga on Sat May 12, 2012 5:49 pm

Hi, I have tried to google around a bit and learn more about how oopenbve renders objects but I could not figure out a little issue that recently showed up. I may not be the only one since it looks like there was a similar post on the openbve forum ... but it's gone.

Anyway let's see if someone can shed some light on this. I ran openbve in Ubuntu and it used to be just fine. Than, I guess since upgrading the OS and therefore mono and the libraries, I don't see the signals facing me anymore. 2/3 or 4 ... I can see the pole, the whole object, but not the front panel with the light. And that's true regardless of using the version from the repositories (1.4.0.9) or download and run latest stable (1.4.1.2).


Interesting LU signals work just fine but not UK rail ones. And again this is true for all the rails including Birmingham X South downloaded (Dec 2010) or from the repositories (June 2010). What really strikes me is that all other objects are OK and signal do work (alas invisibly) since if I pass a closed one I am noticed of that.

I would like to dig in to see if I can find the bug and fix it but no luck so far with my investigation.

briga

Posts : 12
Join date : 2012-05-12

Back to top Go down

Re: OpenBVE signal problem

Post by Dexter on Sat May 12, 2012 8:28 pm

Could that be forgotten Alpha in a png texture?
avatar
Dexter

Posts : 1824
Join date : 2011-07-08
Age : 31
Location : Brno, Czech republic

http://www.brnobve.eu

Back to top Go down

Re: OpenBVE signal problem

Post by graymac on Sat May 12, 2012 10:05 pm

More likely a linux specific problem or a folder structure one. No reported loading errors are mentioned, which could perhaps give a clue.
avatar
graymac

Posts : 1740
Join date : 2011-08-28
Location : Co Mayo, Eire

http://www.celtictrainsim.com

Back to top Go down

Re: OpenBVE signal problem

Post by Dexter on Sat May 12, 2012 10:20 pm

Well, in that case could be sth like lower case and UPPER CASE, ors slash - backslash issue...
avatar
Dexter

Posts : 1824
Join date : 2011-07-08
Age : 31
Location : Brno, Czech republic

http://www.brnobve.eu

Back to top Go down

Re: OpenBVE signal problem

Post by briga on Sun May 13, 2012 5:44 pm

It used to work before but yours are good suggestions and I'll try to set up a couple of VM and see if I can get to the bottom of it.
Yes to me it looked the alpha of it .... but again same files, same tree was fine before .....

The route viewer gives no loading errors (and shows no signal).... I will try to figure it out where openbve logs loading errors now.

briga

Posts : 12
Join date : 2012-05-12

Back to top Go down

Re: OpenBVE signal problem

Post by briga on Thu May 24, 2012 6:22 pm

It's definitely Ubuntu 12.04 vs 11.10 since the latter (in a VM) doesn't have the issue. Here is the signal in his full splendor.





Openbve is the same but the libraries do change .... let's see if I can pin it down.

briga

Posts : 12
Join date : 2012-05-12

Back to top Go down

Re: OpenBVE signal problem

Post by Drag0nflamez on Thu May 24, 2012 6:31 pm

Also, the safety system seems to have been replaced by ATS-P. Good work, Network Rail! /end sarcasm

Drag0nflamez

Posts : 203
Join date : 2012-05-11
Location : The Netherlands

Back to top Go down

Re: OpenBVE signal problem

Post by graymac on Thu May 24, 2012 6:39 pm

Could that mean a plug-in missing?
avatar
graymac

Posts : 1740
Join date : 2011-08-28
Location : Co Mayo, Eire

http://www.celtictrainsim.com

Back to top Go down

Re: OpenBVE signal problem

Post by LabRatAndy on Thu May 24, 2012 7:37 pm

graymac wrote:Could that mean a plug-in missing?

No win32 plug-ins are disabled in non-windows operating systems.


LabRatAndy

Posts : 95
Join date : 2011-08-29

Back to top Go down

Re: OpenBVE signal problem

Post by Drag0nflamez on Thu May 24, 2012 8:12 pm

But you can change the ats.cfg data to this:
Code:
UkTrainSys.dll
if that hasn't happened yet.

Drag0nflamez

Posts : 203
Join date : 2012-05-11
Location : The Netherlands

Back to top Go down

Re: OpenBVE signal problem

Post by briga on Thu May 24, 2012 8:25 pm

Well the difference is on the train. The two screen shots share the same route / openbve but the first one has the linux plugini. I haven't bothered install it in the second one.

briga

Posts : 12
Join date : 2012-05-12

Back to top Go down

Re: OpenBVE signal problem

Post by Riggzy on Sat Jun 16, 2012 4:53 pm

I'm having the same issue with the Birmingham route (signals not showing up but still working, invisibly), on my Mac version of OpenBVE. Other routes using the same train/plugin work fine (i.e. the NWM routes) but not this one. Did you manage to find what the problem was?

Riggzy

Posts : 4
Join date : 2012-06-16

Back to top Go down

Re: OpenBVE signal problem

Post by briga on Sat Jun 16, 2012 8:22 pm

Interesting. I have isolated the problem to some mono libraries (but I have to figure out which one). I am going to try the NWM route and let you know.

briga

Posts : 12
Join date : 2012-05-12

Back to top Go down

Re: OpenBVE signal problem

Post by Riggzy on Mon Jun 18, 2012 7:20 pm

Hm, is it possible in that case that using an older version of Mono (and an appropriately older version of OpenBVE) would get around this problem for now?

Riggzy

Posts : 4
Join date : 2012-06-16

Back to top Go down

Re: OpenBVE signal problem

Post by briga on Mon Jun 18, 2012 7:42 pm

It does for me Riggzy. I have just to use older mono libraries (with the same OpenBVE) to solve it.

briga

Posts : 12
Join date : 2012-05-12

Back to top Go down

Re: OpenBVE signal problem

Post by robbysmith13 on Mon Jun 18, 2012 9:43 pm

if the images for the signals are PNG, Convert them to BMP

robbysmith13

Posts : 28
Join date : 2012-04-09
Age : 18
Location : Bolton, England

Back to top Go down

Re: OpenBVE signal problem

Post by Riggzy on Mon Jun 18, 2012 10:09 pm

Cool - What version of Mono are you using?

(and btw, at time of writing, the current version is 2.10.9 )

Riggzy

Posts : 4
Join date : 2012-06-16

Back to top Go down

Different monos

Post by briga on Tue Jun 19, 2012 10:20 am

OK the working one is this one:
Code:
Mono JIT compiler version 2.10.5 (Debian 2.10.5-1)
Copyright (C) 2002-2011 Novell, Inc, Xamarin, Inc and Contributors. www.mono-project.com
   TLS:          __thread
   SIGSEGV:      altstack
   Notifications: epoll
   Architecture:  amd64
   Disabled:      none
   Misc:          softdebug
   LLVM:          supported, not enabled.
   GC:            Included Boehm (with typed GC and Parallel Mark)
while the one with the issue is:
Code:
Mono JIT compiler version 2.10.8.1 (Debian 2.10.8.1-1ubuntu2.1)
Copyright (C) 2002-2011 Novell, Inc, Xamarin, Inc and Contributors. www.mono-project.com
   TLS:          __thread
   SIGSEGV:      altstack
   Notifications: epoll
   Architecture:  amd64
   Disabled:      none
   Misc:          softdebug
   LLVM:          supported, not enabled.
   GC:            Included Boehm (with typed GC and Parallel Mark)

But my personal take is that it has to do with a specific library I am trying to figure out which one....

No bug:
Code:

libmono-accessibility4.0-cil/oneiric uptodate 2.10.5-1
libmono-addins-gui0.2-cil/oneiric uptodate 0.6.1-2ubuntu1
libmono-addins0.2-cil/oneiric uptodate 0.6.1-2ubuntu1
libmono-cairo4.0-cil/oneiric uptodate 2.10.5-1
libmono-corlib4.0-cil/oneiric uptodate 2.10.5-1
libmono-csharp4.0-cil/oneiric uptodate 2.10.5-1
libmono-data-tds4.0-cil/oneiric uptodate 2.10.5-1
libmono-i18n-cjk4.0-cil/oneiric uptodate 2.10.5-1
libmono-i18n-mideast4.0-cil/oneiric uptodate 2.10.5-1
libmono-i18n-other4.0-cil/oneiric uptodate 2.10.5-1
libmono-i18n-rare4.0-cil/oneiric uptodate 2.10.5-1
libmono-i18n-west4.0-cil/oneiric uptodate 2.10.5-1
libmono-i18n4.0-all/oneiric uptodate 2.10.5-1
libmono-i18n4.0-cil/oneiric uptodate 2.10.5-1
libmono-posix4.0-cil/oneiric uptodate 2.10.5-1
libmono-security4.0-cil/oneiric uptodate 2.10.5-1
libmono-sharpzip4.84-cil/oneiric uptodate 2.10.5-1
libmono-sqlite4.0-cil/oneiric uptodate 2.10.5-1
libmono-system-configuration4.0-cil/oneiric uptodate 2.10.5-1
libmono-system-core4.0-cil/oneiric uptodate 2.10.5-1
libmono-system-data4.0-cil/oneiric uptodate 2.10.5-1
libmono-system-drawing4.0-cil/oneiric uptodate 2.10.5-1
libmono-system-enterpriseservices4.0-cil/oneiric uptodate 2.10.5-1
libmono-system-runtime-serialization-formatters-soap4.0-cil/oneiric uptodate 2.10.5-1
libmono-system-runtime4.0-cil/oneiric uptodate 2.10.5-1
libmono-system-security4.0-cil/oneiric uptodate 2.10.5-1
libmono-system-transactions4.0-cil/oneiric uptodate 2.10.5-1
libmono-system-web-applicationservices4.0-cil/oneiric uptodate 2.10.5-1
libmono-system-web-services4.0-cil/oneiric uptodate 2.10.5-1
libmono-system-web4.0-cil/oneiric uptodate 2.10.5-1
libmono-system-windows-forms4.0-cil/oneiric uptodate 2.10.5-1
libmono-system-xml4.0-cil/oneiric uptodate 2.10.5-1
libmono-system4.0-cil/oneiric uptodate 2.10.5-1
libmono-web4.0-cil/oneiric uptodate 2.10.5-1
libmono-webbrowser4.0-cil/oneiric uptodate 2.10.5-1
libmono-zeroconf1.0-cil/oneiric-updates upgradeable from 0.9.0-2build1 to 0.9.0-3~ubuntu0.1
mono-4.0-gac/oneiric uptodate 2.10.5-1
mono-gac/oneiric uptodate 2.10.5-1
mono-runtime/oneiric uptodate 2.10.5-1
ubuntu-mono/oneiric uptodate 0.0.37

Bug:
Code:
fonts-tlwg-mono/precise uptodate 1:0.4.17-1ubuntu1
libmono-accessibility2.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-accessibility4.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-corlib2.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-corlib4.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-data-tds2.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-data-tds4.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-i18n-cjk4.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-i18n-mideast4.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-i18n-other4.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-i18n-rare4.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-i18n-west2.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-i18n-west4.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-i18n2.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-i18n4.0-all/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-i18n4.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-messaging2.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-posix2.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-posix4.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-security2.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-security4.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-sharpzip2.84-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-sqlite2.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-sqlite4.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-system-configuration4.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-system-core4.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-system-data-linq2.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-system-data2.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-system-data4.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-system-drawing4.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-system-enterpriseservices4.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-system-messaging2.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-system-runtime-serialization-formatters-soap4.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-system-runtime4.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-system-security4.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-system-transactions4.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-system-web-applicationservices4.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-system-web-services4.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-system-web2.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-system-web4.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-system-windows-forms4.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-system-xml4.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-system2.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-system4.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-wcf3.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-web4.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-webbrowser2.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-webbrowser4.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono-winforms2.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
libmono2.0-cil/precise-updates uptodate 2.10.8.1-1ubuntu2.1
mono-4.0-gac/precise-updates uptodate 2.10.8.1-1ubuntu2.1
mono-gac/precise-updates uptodate 2.10.8.1-1ubuntu2.1
mono-runtime/precise-updates uptodate 2.10.8.1-1ubuntu2.1
ubuntu-mono/precise uptodate 0.0.40

briga

Posts : 12
Join date : 2012-05-12

Back to top Go down

Re: OpenBVE signal problem

Post by Riggzy on Tue Jun 19, 2012 7:06 pm

Well, I'm glad it works for you but no luck for me it seems. Possibly a different issue, then. Here's the closest Mono build I could find for Mac:

Code:
Mono JIT compiler version 2.10.5 (tarball Mon Aug 22 20:38:08 EDT 2011)
Copyright (C) 2002-2011 Novell, Inc, Xamarin, Inc and Contributors. www.mono-project.com
   TLS:          normal
   SIGSEGV:      normal
   Notification:  kqueue
   Architecture:  x86
   Disabled:      none
   Misc:          debugger softdebug
   LLVM:          yes(2.9svn-mono)
   GC:            Included Boehm (with typed GC)

And here's the wonderful Barnt Green platform signal:



Riggzy

Posts : 4
Join date : 2012-06-16

Back to top Go down

Re: OpenBVE signal problem

Post by Northern Line on Wed Jun 20, 2012 12:37 pm

Do you have a folder called Br_sigs in your objects folder?
avatar
Northern Line

Posts : 279
Join date : 2011-07-12
Age : 23
Location : Tooting, London, England

http://www.bve-district.co.uk/

Back to top Go down

Re: OpenBVE signal problem

Post by briga on Wed Jun 20, 2012 2:13 pm

The Object folder is called BrSigs (no underscore) and it is under Bham_X-City_South ( Object\Bham_X-City_South\BrSigs\ )
i.e.
Bham_X-City_South\BrSigs\signal3

although there are signal refenced also under Day\Commonfiles and other locations.

Anyway the exact same route works smoothly under a previous version of mono (same OpenBve) so the bug has to be related to the mono version... Sad

briga

Posts : 12
Join date : 2012-05-12

Back to top Go down

Re: OpenBVE signal problem

Post by heyjoe on Fri Jul 06, 2012 1:15 pm

I have exactly the same problem, no signals except for in the nwm routes. just tried installing older mono (10.5) and now open bve won't launch.... running on a mac book pro.... any ideas?

heyjoe

Posts : 2
Join date : 2012-07-06

Back to top Go down

Re: OpenBVE signal problem

Post by heyjoe on Wed Jul 11, 2012 1:39 pm

right well i think i know my problem... I do not have the correct brsigs/br semaphors installed. THis download is unavailable, does anybody know where i can get this? would be much appreciated....

heyjoe

Posts : 2
Join date : 2012-07-06

Back to top Go down

Re: OpenBVE signal problem

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum