OpenBVE 1.5.1.5 and 1.5.1.6 fail to load on MacOS Sierra 10.12.6

View previous topic View next topic Go down

OpenBVE 1.5.1.5 and 1.5.1.6 fail to load on MacOS Sierra 10.12.6

Post by leander5690 on Wed Sep 06, 2017 11:52 pm

Hello,

I notice in the Release Notes for v1.5.1.5 the item "Bumped openTK version". This might be the cause of the problems I'm having, as the routes and trains fail to load. I've attached a copy of the error message window which appears.
Version 1.5.1.4 works fine, so I'm happy to stick with this, if a fix isn't possible.

Thanks.

Dave

Attachments
Screen Shot 2017-07-30 at 22.46.59.png You don't have permission to download attachments.(33 Kb) Downloaded 3 times

leander5690

Posts : 5
Join date : 2017-08-08

Back to top Go down

Re: OpenBVE 1.5.1.5 and 1.5.1.6 fail to load on MacOS Sierra 10.12.6

Post by leezer3 on Thu Sep 07, 2017 12:32 pm

Hmm, not sure off the top of my head.

That error is definitely outside of my immediate control, but updating openTK again might well get us somewhere.

I'm going to try and get a Sierra VM setup, and will try and get this sorted out one way or the other.

leezer3

Posts : 1014
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: OpenBVE 1.5.1.5 and 1.5.1.6 fail to load on MacOS Sierra 10.12.6

Post by leezer3 on Thu Sep 07, 2017 3:04 pm

Try this build, I think this should now work:
https://vps.bvecornwall.co.uk/OpenBVE/Builds/OpenBVE-2017-09-07.dmg

Have just bumped the openTK version again, and it appears to work on a Sierra VM Smile
(Not sure what happened there....)

leezer3

Posts : 1014
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: OpenBVE 1.5.1.5 and 1.5.1.6 fail to load on MacOS Sierra 10.12.6

Post by leander5690 on Fri Sep 08, 2017 2:40 pm

Thank you. The new build works, but only in windowed mode. The iMac full screen mode of 1920 x 1080, and even the lower setting of 1280 x 720, gives an error message: "Failed to change to the selected full-screen resolution: 1024 x 768 32-bit color."

Many thanks for looking into this problem.

leander5690

Posts : 5
Join date : 2017-08-08

Back to top Go down

Re: OpenBVE 1.5.1.5 and 1.5.1.6 fail to load on MacOS Sierra 10.12.6

Post by leezer3 on Fri Sep 08, 2017 3:06 pm

Hmm, not sure...

3D acceleration is rather broken in Mac VMs, and fullscreen doesn't work full-stop with any build for me.
Windowed mode loads but doesn't work at all fast, and this makes it very difficult for me to debug anything Sad

Let me do some digging into the openTK backend, and I'll try and get back to you over the weekend.

In the meantime, 1.5.2.0 has been pushed, which at least works in Windowed mode. (I get the nasty suspicion that this may be a timing issue, and hence work for some people but not others...)

leezer3

Posts : 1014
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: OpenBVE 1.5.1.5 and 1.5.1.6 fail to load on MacOS Sierra 10.12.6

Post by leezer3 on Mon Sep 11, 2017 11:08 pm

Hmm....

VMWare's fullscreen support appears shonky at best (only supports the current desktop resolution....), but now I've figured that out, it would appear to be working OK for me.

Without access to a broken 'real' machine, there's not a lot I can do here, sorry.
Will keep looking, but dunno Sad

leezer3

Posts : 1014
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: OpenBVE 1.5.1.5 and 1.5.1.6 fail to load on MacOS Sierra 10.12.6

Post by leezer3 on Tue Sep 12, 2017 11:32 am

Blind shot in the dark here:

https://vps.bvecornwall.co.uk/OpenBVE/Builds/OpenBVE-2017-09-11.dmg

TLDR:
If switching to a resolution fails, we'll still carry on trying all other resolutions, in case there is another instance with a differing refresh rate which works.

Absolutely no guarantees though Smile

leezer3

Posts : 1014
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: OpenBVE 1.5.1.5 and 1.5.1.6 fail to load on MacOS Sierra 10.12.6

Post by leander5690 on Wed Sep 13, 2017 2:27 pm

Many thanks for your work on this.
Now two separate error messages, in full-screen mode:
"The graphics card driver reported that the selected resolution was not supported: 1024 x 768 32bit color."
and "The route and train loader encountered the following critical error: Object reference not set to an instance of an object".

It works fine in windowed mode, and I can increase the window size to almost the full-screen, so I'm happy with this.
Thanks again.

Dave

leander5690

Posts : 5
Join date : 2017-08-08

Back to top Go down

Re: OpenBVE 1.5.1.5 and 1.5.1.6 fail to load on MacOS Sierra 10.12.6

Post by Quork on Wed Sep 13, 2017 3:26 pm

Wouldn't that rather indicate the GPU driver to be bodged?
avatar
Quork

Posts : 1106
Join date : 2012-05-05
Age : 26
Location : Hofheim a.T., Hessen (Hesse), European Union

Back to top Go down

Re: OpenBVE 1.5.1.5 and 1.5.1.6 fail to load on MacOS Sierra 10.12.6

Post by leander5690 on Wed Sep 13, 2017 3:48 pm

I'm using the latest MacOS Sierra 10.12.6, which has the current drivers built-in, so I am unable to change them.

leander5690

Posts : 5
Join date : 2017-08-08

Back to top Go down

Re: OpenBVE 1.5.1.5 and 1.5.1.6 fail to load on MacOS Sierra 10.12.6

Post by leezer3 on Wed Sep 13, 2017 3:58 pm

Quork wrote:Wouldn't that rather indicate the GPU driver to be bodged?

It's a Mac, no such thing as drivers Razz

I can't explain the critical error (Manually setting a completely unsupported resolution in code just produces the first error box here), but it's definitely something machine related.
What exactly, I don't know Sad

Can I just check:
Have you tried setting the full-screen resolution to *exactly* your desktop resolution (27" non-retina models are 2560 x 1440, 21.5" non-retina models are 1920x1080)

I'll raise a bug with openTK, as all I'm doing is making a standard function call, and this needs someone with a real machine to test properly though.

Edit:
Oddities in full-screen resolution behaviour don't appear to be isolated to openBVE with iMacs:
https://forum.warthunder.com/index.php?/topic/290025-no-fullscreen-when-in-non-native-resolution/
http://forum.amanita-design.net/index.php?topic=1381.0

leezer3

Posts : 1014
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: OpenBVE 1.5.1.5 and 1.5.1.6 fail to load on MacOS Sierra 10.12.6

Post by leander5690 on Wed Sep 13, 2017 4:08 pm

Yes, my screen is definitely set to 1920 x 1080.

leander5690

Posts : 5
Join date : 2017-08-08

Back to top Go down

Re: OpenBVE 1.5.1.5 and 1.5.1.6 fail to load on MacOS Sierra 10.12.6

Post by Quork on Wed Sep 13, 2017 4:18 pm

leezer3 wrote:It's a Mac, no such thing as drivers Razz
Oh, my bad Laughing
avatar
Quork

Posts : 1106
Join date : 2012-05-05
Age : 26
Location : Hofheim a.T., Hessen (Hesse), European Union

Back to top Go down

Re: OpenBVE 1.5.1.5 and 1.5.1.6 fail to load on MacOS Sierra 10.12.6

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum