Leezer: Another crash

View previous topic View next topic Go down

Leezer: Another crash

Post by edgreenberg on Sat May 06, 2017 1:14 am

Hey there,

This is a dialog box crash while running.  Using 1.5.1.1, which cleared all the train loading problems I had. Thank you very much.

This is on the London Central Line using the Class 482.  

Log and Crash log attached. 

Best,
Ed G

edgreenberg

Posts : 26
Join date : 2017-04-13

Back to top Go down

Re: Leezer: Another crash

Post by leezer3 on Sat May 06, 2017 12:41 pm

Nothing attached Sad

I can't immediately reproduce this one from a quick run down the Central Line with the 482. (I'm presuming these are both Dan Lewis's most recent versions, not the original ones from TSC?)

Will take a look when we get the crash log Smile

leezer3

Posts : 1014
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

attachment

Post by edgreenberg on Sat May 06, 2017 1:18 pm

Honestly, I don't know where I got it, but I got it only last week.

Trying again on the attachment.
Attachments
londoncentralcrash.zip You don't have permission to download attachments.(4 Kb) Downloaded 4 times

edgreenberg

Posts : 26
Join date : 2017-04-13

Back to top Go down

Re: Leezer: Another crash

Post by edgreenberg on Sat May 06, 2017 1:20 pm

It should be noted that I'm not trying to be a complainer or PITA.  I see it as just reporting issues and doing a bit of QA.  I have plenty of things that work fine to keep me busy, what with OpenBVE, TS2017 and even OpenRails.

If you want me to back off, or if you don't get back to me promptly, I won't be the least bit offended.

E

edgreenberg

Posts : 26
Join date : 2017-04-13

Back to top Go down

Re: Leezer: Another crash

Post by leezer3 on Sat May 06, 2017 2:16 pm

No trouble, I'd much rather find these things Smile
It's much harder to do so when no-one reports them to me; There are '00s of ways something can be non-standard, and it only takes one for things to break.

This one was caused by the 482 having a sound.cfg file present, but not having all properties defined within the file.
A change in 1.5.1.0 allowed for index specific point sounds, but didn't handle this case correctly. This led to the point sound being null, and things promptly broke when we hit a set of points.
(An aggravating factor is that the first few sets of points on the Central Line/ Waterloo and City are 'non-standard', meaning that it looks OK at first glance.....)

https://vps.bvecornwall.co.uk/OpenBVE/Builds/OpenBVE-2017-05-06.zip

This one should work OK, please let me know!

leezer3

Posts : 1014
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: Leezer: Another crash

Post by cilldroichid on Sat May 06, 2017 2:24 pm

Hi,

I'm also experiencing a crash on the central line, . I downloaded the route from Dexter's website which I think is the up to date version. The crash happens on the junction between West and North Acton at around the 5650 metres position driving the default 1992 tube stock, I lowered the viewing distance and graphics settings but it still crashed in the same position.


I've ran a fair amount routes and it's the only crash I've had to date on the newer versions of OpenBVE, the only other minor bug I have is the review last game screen does not work it is stuck on the first route I ran and has not updated since. It's great to see continued development of the OpenBVE program, I really like the new F8 hud options,  the map is very helpful in anticipating upcoming stations.


Donal.


*Edit: Leezer3 posted while I was writing this post, I will try the fix.

cilldroichid

Posts : 12
Join date : 2014-09-28

Back to top Go down

Re: Leezer: Another crash

Post by cilldroichid on Sat May 06, 2017 2:35 pm

The fix got me past the site of the previous crashes, it looks like it worked. I will run the whole route later on and report back

Thanks,

Donal.

cilldroichid

Posts : 12
Join date : 2014-09-28

Back to top Go down

Re: Leezer: Another crash

Post by leezer3 on Sat May 06, 2017 2:37 pm

cilldroichid wrote:I've ran a fair amount routes and it's the only crash I've had to date on the newer versions of OpenBVE, the only other minor bug I have is the review last game screen does not work it is stuck on the first route I ran and has not updated since. It's great to see continued development of the OpenBVE program, I really like the new F8 hud options,  the map is very helpful in anticipating upcoming stations.

This one isn't actually a bug per-se.
To fix:
Options ==>
Detail of Simulation ==>
Check the 'Enable Black Box' checkbox.

There is a possible argument for disabling the Review Game screen if the black box is not enabled, but I'm not sure that's the best idea. (In 1.4.3, the 'Enable Black Box' checkbox was broken entirely, so the Review Game screen always worked)
I'll think about that one some more, as I'm sure this can be handled a little better Smile

leezer3

Posts : 1014
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: Leezer: Another crash

Post by edgreenberg on Sat May 06, 2017 4:33 pm

I think you've fixed this. I got from Ealing to Marble Arch.  Gotta stop though. I have an electrician coming to do some work (in real life).

Thanks,

Ed

edgreenberg

Posts : 26
Join date : 2017-04-13

Back to top Go down

Re: Leezer: Another crash

Post by cilldroichid on Sun May 07, 2017 7:12 pm

leezer3 wrote:
Check the 'Enable Black Box' checkbox.


That done the trick, I must have unticked it after my first run .

The central line works from start to finish with your latest version.

Thanks.

cilldroichid

Posts : 12
Join date : 2014-09-28

Back to top Go down

Re: Leezer: Another crash

Post by leezer3 on Fri May 12, 2017 12:06 pm

1.5.1.2 is now available as the current build on the main site ( http://openbve-project.net ) , which contains this fix.

Closing thread Smile

leezer3

Posts : 1014
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: Leezer: Another crash

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum