BVE4:Pitch command

View previous topic View next topic Go down

BVE4:Pitch command

Post by mfonda on Wed Oct 12, 2016 11:00 pm

Hello guys: BVE4 Pitch command no longer works; neither up or down. Track remains at 3m. Tried all sorts of ways, but no go. The old routes are still OK. It is just the new coding that is off. Any ideas?

mfonda

Posts : 2
Join date : 2016-10-12

Back to top Go down

Re: BVE4:Pitch command

Post by tof63 on Wed Oct 12, 2016 11:39 pm

Can you show the code of your route file affected with this problem?
avatar
tof63

Posts : 37
Join date : 2012-05-08
Location : Turin (Italy)

http://bve.altervista.org/index.html

Back to top Go down

Re: BVE4:Pitch command

Post by graymac on Thu Oct 13, 2016 10:20 am

I'm using the latest build of the updated program (1.4.254.752) and there seem to be no problems with existing routes, I haven't coded any new track involving pitch changes lately, though if the commands weren't being recognised by the program I'm sure it would be noticeable!!!

BVE4 is obsolete now, but the correct coding for OpenBVE is as follows:

Track.Pitch Rate
Rate: A floating-point number measured in per thousands representing the pitch of the track. The default value is 0.
This command defines the pitch of all rails from this point on. Negative values indicate a downward gradient, positive ones an upward gradient. The value of 0 represents a level track. Rate can be calculated from a length difference X and a height difference Y in the following way:
Rate expressed through X and Y:
ƒRate = 1000 * Y / X
  This command can only be used at the beginning of a block. 
avatar
graymac

Posts : 1741
Join date : 2011-08-28
Location : Co Mayo, Eire

http://www.celtictrainsim.com

Back to top Go down

Re: BVE4:Pitch command

Post by MattD6R on Thu Oct 13, 2016 12:45 pm

No problems also here with pitch commands on current routes using 1.4.255.1340 version of the updated program. Are you sure you have the syntax right with a comma (,) between commands, full stop (.) preceding the command name and semi colon (; ) between different parameters of a command. Mixing this up will cause problems.

For example:
Code:
500,.Curve 500;40,.Pitch 2,

or:

Code:
500,
.Curve 500;40,
.Pitch 2,
In this second way with each command on separate lines you don't have to add the comma at the end of each command but you can if you wish.

MattD6R

Posts : 243
Join date : 2013-06-16
Location : Brisbane, Australia

Back to top Go down

BVE4:Pitch command

Post by mfonda on Thu Oct 13, 2016 3:57 pm

Hello Again:I have not been able to find the problem. However, since the Schiphol-Zwolle route is essensially the same, part of the way, as the Schiphol-Enschede route, I have simply transferred the beginning of the 
Zwolle route that was OK to the Enschede route. The problem must have been a coding mistake, that I have not found as yet. I have uploaded the new 400 Schiphol route to my website. I have not been able (or willing)
to do much work lately, but I have now started to do some more work on these 2 routes. I would like to at least finish one. Thanks for the input. Nice to hear from you again, Luigy. Hope you are well. Cheers, Martin

mfonda

Posts : 2
Join date : 2016-10-12

Back to top Go down

Re: BVE4:Pitch command

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum