openBVE Keyboard fail

View previous topic View next topic Go down

openBVE Keyboard fail

Post by Dexter on Thu May 12, 2016 7:44 pm

So... I had tried to run the new build "Travis" to check the fps differences between the old and the new version, but I failed. My keyboard is not working in the sim. And I don't know why, I do not get any errors...


Last edited by Dexter on Sat May 14, 2016 6:14 pm; edited 1 time in total
avatar
Dexter

Posts : 1795
Join date : 2011-07-08
Age : 31
Location : Brno, Czech republic

http://www.brnobve.eu

Back to top Go down

Re: openBVE Keyboard fail

Post by leezer3 on Thu May 12, 2016 10:19 pm

Working perfectly here, so let's start with some basics:
Does the ESC key pull up the menu?
Similarly, do the arrow keys work to move the camera?

Both of these should be the same on any keyboard layout. Not sure what you're running (Czech?) but that might be a factor.
Also, have you remembered that any custom keyboard configurations set will not carry over from Odakyufan's last build, and will have to be recreated manually?

Will do some testing on your optimised version and see what the difference is like there too at some stage Smile

Cheers

Chris Lees

http://www.bvecornwall.co.uk

leezer3

Posts : 839
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: openBVE Keyboard fail

Post by Dexter on Fri May 13, 2016 5:34 am

Nope, none of the game controls work, not even Esc or F10. The only combinations that seem to work are the Windows ones (Windows key, ALT+TAB...). It is not your fault though, as today I had tried the last "official" build and it was pretty much the same. I will need to dig deeper.
Also got a popup - "oalwrapper could not initiate properly", so I am thinking that might be the reason. Never had that before and I have not changed anything on my PC since then (except for installing Far Cry Primal), so it makes me think a little... scratch
avatar
Dexter

Posts : 1795
Join date : 2011-07-08
Age : 31
Location : Brno, Czech republic

http://www.brnobve.eu

Back to top Go down

Re: openBVE Keyboard fail

Post by Dexter on Fri May 13, 2016 8:02 pm

Well, the only key that appears to be working in the sim is F8, which brings the route map and route height. Other than that, I am stuck and desperate. No idea what this is. Sad 1.4.1 and 1.2.12 having the same issue. I can use my mouse to rotate the camera. YAY!
avatar
Dexter

Posts : 1795
Join date : 2011-07-08
Age : 31
Location : Brno, Czech republic

http://www.brnobve.eu

Back to top Go down

Re: openBVE Keyboard fail

Post by leezer3 on Sat May 14, 2016 12:38 pm

Dunno, never had that before Sad
F8 working suggests that something at operating system level is blocking things- All the keys go through the same process, so if one works, all should work.

You could try the extremely long shot of resetting all the controls to default, but I can't see what that would do for you....

What version of Windows are you running? I've tested XP, 7 and 8, but not 10.
I've also done some briefer testing on an OS-X and Linux virtual machines.

Any antivirus?
There was a problem with an antivirus blocking this at the start of the thread, would have to dig back and see what though....

Cheers

Chris Lees

http://www.bvecornwall.co.uk

leezer3

Posts : 839
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: openBVE Keyboard fail

Post by Quork on Sat May 14, 2016 4:55 pm

Could it by a plugin problem? Dex did you try a vehicle with no plugin at all?
avatar
Quork

Posts : 1054
Join date : 2012-05-05
Age : 25
Location : Hofheim a.T., Hessen (Hesse), European Union

Back to top Go down

Re: openBVE Keyboard fail

Post by Dexter on Sat May 14, 2016 6:12 pm

Yes, I have tried a couple of different trains and routes. Running openBVE as admin and on Win7 64bit, version Ultimate.
I have got Avast.
The strange thing it was not causing any issues before...
I have realized I have got the Vulcan engine installed now. Could that make any difference?
avatar
Dexter

Posts : 1795
Join date : 2011-07-08
Age : 31
Location : Brno, Czech republic

http://www.brnobve.eu

Back to top Go down

Re: openBVE Keyboard fail

Post by Dexter on Sat May 14, 2016 6:20 pm

So, resetting the controls did the trick. However, I do not see the animated pantographs of my trains now... LOL what's going on there. Very Happy
avatar
Dexter

Posts : 1795
Join date : 2011-07-08
Age : 31
Location : Brno, Czech republic

http://www.brnobve.eu

Back to top Go down

Re: openBVE Keyboard fail

Post by leezer3 on Sat May 14, 2016 11:24 pm

Hmm, I can reproduce the pantograph issues, looks like a bug has crept in somewhere with the bogie implementation.

Digging.....

Cheers

Chris Lees

http://www.bvecornwall.co.uk

leezer3

Posts : 839
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: openBVE Keyboard fail

Post by leezer3 on Sat May 14, 2016 11:47 pm

Gotcha Smile

Give it about 10 mins for the build server to run up the new build and all should be well with your pantographs.
(It was the animated object speedup- Double.TryParse was overwriting the out value with null when it didn't succeed, and this was messing up the position......)

Edit:
http://vps.bvecornwall.co.uk/OpenBVE/Builds/OpenBVE-2016-05-14.tar.gz
http://vps.bvecornwall.co.uk/OpenBVE/Builds/OpenBVE-2016-05-14.dmg

Tested and working with your pantographs.

Cheers

Chris Lees

http://www.bvecornwall.co.uk

leezer3

Posts : 839
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: openBVE Keyboard fail

Post by Dexter on Sun May 15, 2016 5:00 pm

It is working now, thanks. :-) Avast was trying to persuade me, that this build is a huge threat to my PC, though.
avatar
Dexter

Posts : 1795
Join date : 2011-07-08
Age : 31
Location : Brno, Czech republic

http://www.brnobve.eu

Back to top Go down

Re: openBVE Keyboard fail

Post by Quork on Sun May 15, 2016 5:20 pm

Very strange - my Avast (11.2.2262, malware database 160515-0) doesn't object neither to the package nor to the unpacked files.
avatar
Quork

Posts : 1054
Join date : 2012-05-05
Age : 25
Location : Hofheim a.T., Hessen (Hesse), European Union

Back to top Go down

Re: openBVE Keyboard fail

Post by Dexter on Sun May 15, 2016 9:55 pm

Really strange then, same version and same database on my PC... yet openBVE.exe was deleted. I took it out of the scan procedure then...
avatar
Dexter

Posts : 1795
Join date : 2011-07-08
Age : 31
Location : Brno, Czech republic

http://www.brnobve.eu

Back to top Go down

Re: openBVE Keyboard fail

Post by leezer3 on Mon May 16, 2016 2:58 pm

No comment- Heuristics can be a funny thing sometimes.

Once there's a stable version (Soon.......) if we get any issues, I can always start chasing AV vendors to fix this permanently.
I had reasonable success when they started blocking OS_ATS except for the odd foreign vendors, who I can't do much about.

To note:
One more bug fixed in today's build, which could have resulted in some cases having an incorrect Y or Z rotation in a calculation with a static result Sad

Hopefully that's all the kinks out of it, although I stand to be corrected!

Cheers

Chris Lees

http://www.bvecornwall.co.uk

leezer3

Posts : 839
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: openBVE Keyboard fail

Post by Quork on Mon May 16, 2016 7:01 pm

Are you sure your download wasn't corrupted? I think it is in the realm of possibility. Would it be possible to have checksums for the downloads, Chris?
avatar
Quork

Posts : 1054
Join date : 2012-05-05
Age : 25
Location : Hofheim a.T., Hessen (Hesse), European Union

Back to top Go down

Re: openBVE Keyboard fail

Post by MattD6R on Mon May 16, 2016 9:40 pm

Chris, you are probably aware of this but Norton does block your site. But I can still access and download files without issues, though its slightly annoying. Norton report: https://safeweb.norton.com/report/show?url=http:%2F%2Fwww.bvecornwall.co.uk%2Fwordpress%2F&product=N360&version=22.6.0.142&lang=0901&source=toolbar

MattD6R

Posts : 221
Join date : 2013-06-16
Location : Brisbane, Australia

Back to top Go down

Re: openBVE Keyboard fail

Post by leezer3 on Mon May 16, 2016 10:46 pm

Goes away to bash head on wall.....

I went through this idiocy about 2 years ago when every AV software suddenly decided OS_ATS was a virus....
They also went after some of the WinRAR SFX installers, but they seem to have added another bunch to the heuristics at some stage relatively recently.

Sending some mails, will see what we can do......

Note:
Whilst I've scanned everything on my site as clean, please make your own judgements.

Cheers

Chris Lees

http://www.bvecornwall.co.uk

leezer3

Posts : 839
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: openBVE Keyboard fail

Post by leezer3 on Mon May 16, 2016 11:19 pm

Further note, depending on what happens with the round of mails I've just sent, I may just stick BVEC_ATS onto the Scotsman / 117 and recompress.

I'm loathe to do anything with them though, they're both 12 years old, and I'd quite like to keep them in original form for posterity Razz

Cheers

Chris Lees

http://www.bvecornwall.co.uk

leezer3

Posts : 839
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: openBVE Keyboard fail

Post by leezer3 on Wed May 18, 2016 1:47 pm

OK, Norton and most of the non Chinese antivirus vendors fixed.....

Matt, can you see what you get now?

Cheers

Chris Lees

http://www.bvecornwall.co.uk

leezer3

Posts : 839
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: openBVE Keyboard fail

Post by MattD6R on Wed May 18, 2016 10:08 pm

No more blocking and works fine now. Thanks.Smile

MattD6R

Posts : 221
Join date : 2013-06-16
Location : Brisbane, Australia

Back to top Go down

Re: openBVE Keyboard fail

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum