'Proper' Bogie Motion!

Page 2 of 2 Previous  1, 2

View previous topic View next topic Go down

Re: 'Proper' Bogie Motion!

Post by Dexter on Thu Jun 16, 2016 8:58 pm

Yeah, it seems to be acting up for some reason...

Dexter

Posts : 1780
Join date : 2011-07-08
Age : 31
Location : Brno, Czech republic

http://www.brnobve.eu

Back to top Go down

Re: 'Proper' Bogie Motion!

Post by leezer3 on Thu Jun 16, 2016 9:09 pm

For reference, the attached is what I'm seeing, using the same code for the bogies and extensions.cfg. 100% as intended (I may have deleted some of the chassis, but don't mind that....)

Something is obviously funky though.
If I delete the axles values from the car and let it use the default axle positions from the train.dat, it pushes the bogies out in front and behind the loco.
You would appear to have both offset to the rear, so that suggests that it's at least parsing something from the extensions.cfg , but that it's wrong.

Any chance of the log please?

Again, I'm by no means sure it'll tell us anything, but it will help eliminate some possibilities.

Quork-
They'll almost certainly pivot as intended, but at the wrong placement.

Cheers

Chris Lees

http://www.bvecornwall.co.uk
Attachments
754.jpg You don't have permission to download attachments.(20 Kb) Downloaded 4 times

leezer3

Posts : 750
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: 'Proper' Bogie Motion!

Post by leezer3 on Thu Jun 16, 2016 9:22 pm

Found:
It's the length value stuffing it up.....

That's altering the axle positions.

A length value is not valid for a bogie, as it's not a collision object, and it can't alter the position of other cars.

As soon as TravisCI completes today's build, this will be correctly warned about, and your problem should go away.
You can also just delete the length value Smile

Cheers

Chris Lees

http://www.bvecornwall.co.uk

leezer3

Posts : 750
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: 'Proper' Bogie Motion!

Post by Dexter on Thu Jun 16, 2016 10:41 pm

Confirmed as working, thanks! Smile The 754s with working bogies will see the light of the download page soon!  Wink

Dexter

Posts : 1780
Join date : 2011-07-08
Age : 31
Location : Brno, Czech republic

http://www.brnobve.eu

Back to top Go down

Re: 'Proper' Bogie Motion!

Post by Sponsored content Today at 10:26 pm


Sponsored content


Back to top Go down

Page 2 of 2 Previous  1, 2

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum