New OpenBVE Build- Testers Please

Page 15 of 17 Previous  1 ... 9 ... 14, 15, 16, 17  Next

View previous topic View next topic Go down

Re: New OpenBVE Build- Testers Please

Post by leezer3 on Sun Apr 17, 2016 7:37 pm

Fixed as soon as it builds the newest version Smile

Technical diagnosis:
When disposing of a train, all associated objects must be hidden by the renderer.
I'd forgotten to check whether any bogie objects were defined, and hence was trying to dispose of non-existent objects.

I'm actually surprised no-one else found this one, first Razz

Edit:
Builds are now up, should be dated 17.04.2016, build number will be 1.4.80.116

Cheers

Chris Lees

http://www.bvecornwall.co.uk

leezer3

Posts : 750
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by Dj Hammers on Mon Apr 18, 2016 2:26 am

Wonderful! Program works again! Thank you so much for your dedication!!!

Really looking forward to the implementation of the upcoming features you guys have outlined! Very Happy

Dj Hammers

Posts : 80
Join date : 2012-05-08
Age : 20
Location : United States

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by leezer3 on Thu Apr 21, 2016 6:08 pm

The latest build has a few more minor reliability patches added-

  • Main form now closes fully under Linux, rather than hanging around in the background. (This is a workaround for what's probably a Mono bug)
  • The main form no longer freezes completely when pre-processing a large route, but instead remains responsive and shows an appropriate 'Please Wait' message.
  • It's now possible to use ALT + F4 to close the sim.


Cheers

Chris Lees

http://www.bvecornwall.co.uk

leezer3

Posts : 750
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by MattD6R on Thu Apr 21, 2016 9:35 pm

Using the latest build the close message appears when I only press F4 as well as the ALT + F4. As a result I can't use the F4 camera as the quit message comes up instead.

MattD6R

Posts : 214
Join date : 2013-06-16
Location : Brisbane, Australia

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by leezer3 on Thu Apr 21, 2016 11:53 pm

Interesting, that would appear to be an openTK bug, as checking the flag bitwise ought to work Sad
(The documentation states it's mildly faster, and I was only trying to catch the left ALT key, as opposed to both)

Have fixed by switching to the 'other' method, new build should now be up.

One other rather obscure fix from this afternoon:

  • Routes using a parenthesis in the station name [ '(' and ')' ] should now work correctly.

This affects some BVE2 era routes, for example this:
http://uffaeriuffa.altervista.org/av/avindice.htm

Cheers

Chris Lees

http://www.bvecornwall.co.uk

leezer3

Posts : 750
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by MattD6R on Fri Apr 22, 2016 3:17 am

Using the new build it works properly with the close message only if I press ALT +F4 and the camera when F4 is used.

MattD6R

Posts : 214
Join date : 2013-06-16
Location : Brisbane, Australia

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by phontanka on Sun May 01, 2016 2:04 am

I've just had a chance to test your April 21 build on Ubuntu 16.04 and I can say it's a decent improvement. Window resizing while playing works correctly and the startscreen disappears when loading a route. I ran two route files, they seem to work fine.

Two minor things I noticed:

1. On the Customize controls page the keys for the controls don't appear when a control is clicked on the list (though they work).


2. On the Options page there are some minor visual glitches.

(I forgot to circle Number of allowed sounds here.)

Thanks for all your work, Chris!

phontanka

Posts : 215
Join date : 2012-05-08
Location : Hungary

http://phontanka.wordpress.com

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by Quork on Sun May 01, 2016 10:14 am

What happened to the layout? That's totally weird, completely different from what it looks like for me. Has it always been so on Linux?!

Quork

Posts : 1031
Join date : 2012-05-05
Age : 25
Location : Frankfurt am Main (Frankfurt on Main), Hessen (Hesse), European Union (Deutschland (Germany))

http://www.parkbahnschmiden.de/

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by leezer3 on Sun May 01, 2016 10:21 am

Will take a proper look tonight- Looks like text padding/ anchoring issues on all of them except the missing control key display. (That's going to be the translation tweaks I made)
Must have got an anchor value wrong somewhere- If you resize the window slightly I think they'll all stay in place, whilst they should dynamically adjust to fit.

Should be easy enough to fix, as I think they'll be broken on any Mono system Smile

Final note- The most recent build (May 30 IIRC) changes the radio-buttons on the left to buttons to be consistent with Windows. I think these should work 100% but I did have to fiddle with some color changing glitches....

Cheers

Chris Lees

leezer3

Posts : 750
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by phontanka on Sun May 01, 2016 12:43 pm

This is what I see with a fullscreen window:



May 30? Isn't the one at the top here: http://vps.bvecornwall.co.uk/OpenBVE/Builds/ the latest build, or do I look somewhere else for new builds?

phontanka

Posts : 215
Join date : 2012-05-08
Location : Hungary

http://phontanka.wordpress.com

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by leezer3 on Sun May 01, 2016 1:13 pm

April 30 Wink

The build doesn't seem to have auto-uploaded either, will kick it when I'm home from work.....
(That's what comes of posting from the phone)

Cheers

Chris Lees

leezer3

Posts : 750
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by leezer3 on Sun May 01, 2016 8:35 pm

Kicked Razz

Should now have a 1st of May build up there.
Fixes relevant to your post:

  • Keyboard key now changes with control selection.
  • The 'Enable Black Box' label could be misplaced. (Not listed, but I spotted that)


The others are the fault of the default font Mono is choosing. The character kerning (size) seems to be different to the default on Windows, and so the string measurements are wrong. I need to see if I can fix this without breaking the UI spacing somewhere else.....
I'm fiddling around with it, and will see if I can make things better.

Cheers

Chris Lees

http://www.bvecornwall.co.uk

leezer3

Posts : 750
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by phontanka on Sun May 01, 2016 8:56 pm

Just tried the May 1 version on Windows 10 in a brand new folder and saw that anti-aliasing was by default at level 0. I guess it should be at maximum by default.

phontanka

Posts : 215
Join date : 2012-05-08
Location : Hungary

http://phontanka.wordpress.com

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by phontanka on Sun May 01, 2016 9:02 pm

Some placement issues are still present in this build (not that they are the most important thing):

phontanka

Posts : 215
Join date : 2012-05-08
Location : Hungary

http://phontanka.wordpress.com

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by leezer3 on Sun May 01, 2016 9:10 pm

Stupid question:
What's actually wrong with the Timetable mode now?

The only really obvious thing I can see is that the form might be cutting off the bottom of the dropdown box?
Or are you referring to the fact it's not quite perfectly aligned?
Just want to make sure I'm looking at the same thing you are Smile

Cheers

Chris Lees

leezer3

Posts : 750
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by phontanka on Sun May 01, 2016 9:19 pm

Yes, the missing part of the dropdown is one thing.

The other is the placement of the phrase Timetable mode, it's not aligned in front of the dropdown like other options are above it, for example Transparency, Level of anti-aliasing, Level of anisotropic filtering, etc.

The third thing is that all other options have a colon at the end but Timetable mode doesn't.

Maybe the window should be slightly larger to give more room to all these. Again, this is not the most important thing, I just saw it and thought I'd let you know, but work on actual features is more important.

phontanka

Posts : 215
Join date : 2012-05-08
Location : Hungary

http://phontanka.wordpress.com

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by leezer3 on Sun May 01, 2016 9:33 pm

Fixing little cosmetic issues is therapeutic, and it really helps with making this look a little more professional Razz
(Don't try getting a file/ folder picker dialog to work reliably on both Windows and Mono, it's a nightmare.....)

Will sort the aligment and cutoff now we're both looking at the same thing.
The missing colon isn't in the language files, hadn't noticed that. Will change.

Probably ought to resize the window a little, but the mad thing is that it's perfect on Windows (The kerning issue....)
You might also have noticed that depending on the window size the ansiotropic text can get cut off, and I need to see if I can get a workaround in place properly.
Again, this is all Mono specific issues......

Cheers

Chris Lees

leezer3

Posts : 750
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by Dj Hammers on Wed May 11, 2016 4:08 pm

I have given some thought to the usability of the program after having to explain to multiple people how to install and use openBVE.
One of the main issues that most laypeople run in to when trying to install openBVE is dealing with installing the program.

Perhaps an online installer can be created.
Such an installer would be downloaded by the user.

Upon launch, the installer will fetch from an online server (I would assume this would be leezer's site) the newest stable or development build of openBVE (user's choice as to which version to install) and install it in the proper directory.

If dependencies can not be included for whatever reason in the main openBVE install process, perhaps the installer can automatically download (or come with) the installer packages for openBVE's dependencies and launch them following the installation of the main openBVE program.

I figure this would go well alongside the content manager feature, which itself will significantly reduce the learning curve of the program.

Dj Hammers

Posts : 80
Join date : 2012-05-08
Age : 20
Location : United States

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by leezer3 on Wed May 11, 2016 4:35 pm

All dependencies are included in all current nightly builds, and will be prompted for automatically if required Smile

When we have a completely stable version, I will also build an installer- That's very much on my list, and isnt hard. (Another foible of Michelle...)

Packages are now fundamentally most of the way there, but I've hardly started on trying to work out all the problems.

Cheers

Chris Lees

leezer3

Posts : 750
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by Dj Hammers on Wed May 11, 2016 4:46 pm

leezer3 wrote:All dependencies are included in all current nightly builds, and will be prompted for automatically if required Smile

When we have a completely stable version, I will also build an installer- That's very much on my list, and isnt hard. (Another foible of Michelle...)

Packages are now fundamentally most of the way there, but I've hardly started on trying to work out all the problems.

Cheers

Chris Lees
That is wonderful news! I am so glad that the program will transition to being much more user-friendly. Thank you so much for all of your contributions!

What constitutes a "stable" version, out of curiosity? I'd assume that no stable version will be released until packages are fully implemented and there has been a round for Beta testing to zap any bugs?

Dj Hammers

Posts : 80
Join date : 2012-05-08
Age : 20
Location : United States

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by Quork on Wed May 11, 2016 11:12 pm

Also great news is what you wrote in Dex's First Brno Track thread: OpenBVE recognising static formulae as such and thus not reevaluating them every frame is really a big step forward.

Quork

Posts : 1031
Join date : 2012-05-05
Age : 25
Location : Frankfurt am Main (Frankfurt on Main), Hessen (Hesse), European Union (Deutschland (Germany))

http://www.parkbahnschmiden.de/

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by leezer3 on Wed May 11, 2016 11:15 pm

Today's build contains a change which provides a considerable speed-up with certain configurations of animated objects,

If your animated object contains a static function result, e.g:
[Object]
states = Object.csv
Position = 0,0,0
;;Rotate the object through 90 degrees
RotateXFunction = 1.5708

Rotation and Translation functions with a static result are now applied once upon object load instead of being checked each frame.

This provides a FPS boost of ~50% in some areas on the previous version of First Brno Track, but this is an edge case, and the actual gains will depend heavily upon the number of animated objects in use, and whether any static function results are used.

Quork wrote:Also great news is what you wrote in Dex's First Brno Track thread: OpenBVE recognising static formulae as such and thus not reevaluating them every frame is really a big step forward.

Posted at the same time as me Razz

First Brno Track is very much an edge case, and this isn't nearly as good as it looks Very Happy
All I'm actually doing just at the moment is a simple check as to whether the entered function can be parsed into a number, and if so applying this directly to the object at load time.

NWM and the Plymouth Route (Two more major FPS killers) see minimal to no FPS gains depending on where you are in the route-
This will help with people who're using animated files as an object container, but will have absolutely no effect otherwise.

I'm thinking about how to check whether a nested function will always return the same result, but this is harder than it looks Razz


Cheers

Chris Lees

http://www.bvecornwall.co.uk

leezer3

Posts : 750
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by Dj Hammers on Wed May 11, 2016 11:25 pm

It seems as if a .DMG download for Mac was not generated for the most recent build.

Dj Hammers

Posts : 80
Join date : 2012-05-08
Age : 20
Location : United States

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by leezer3 on Wed May 11, 2016 11:33 pm

Kicked.....

Should now be there, dunno why Travis failed to find Mono, but worked just fine when the build was restarted Sad

Cheers

Chris Lees

http://www.bvecornwall.co.uk

leezer3

Posts : 750
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by leezer3 on Wed May 11, 2016 11:55 pm

Apologies, if you've downloaded in the last hour or so, please do so again- The previous build included a typo where non-static rotation for the Z-axis would actually be applied on the Y-axis......
Both builds have now regenerated.


Another fix incoming for this change as soon as the build server regenerates.

Cheers

Chris Lees

http://www.bvecornwall.co.uk

leezer3

Posts : 750
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by Sponsored content Today at 10:27 pm


Sponsored content


Back to top Go down

Page 15 of 17 Previous  1 ... 9 ... 14, 15, 16, 17  Next

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum