New OpenBVE Build- Testers Please

Page 14 of 17 Previous  1 ... 8 ... 13, 14, 15, 16, 17  Next

View previous topic View next topic Go down

Re: New OpenBVE Build- Testers Please

Post by MattD6R on Wed Mar 23, 2016 8:27 pm

Using your last auto generated build I still get some issues with Unload Unused Textures. When driving some textures appear white as they are approached and then render correctly when closer to the texture. Using F3 some of the time textures can turn white but at the camera position as well as further ahead along the route.

MattD6R

Posts : 212
Join date : 2013-06-16
Location : Brisbane, Australia

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by leezer3 on Wed Mar 23, 2016 10:50 pm

Timetable textures I can actually understand, and will see if I can fix.
The others, dunno- I managed to reproduce with one NWM routefile, and the new method solved that for me Sad

Which routefile please?
(I'd like to take a closer look at the textures in use, and whether there are any animated objects in play)

This option is definitely becoming a pain in the neck.
Other than for testing purposes, please only enable if you need it, which AFAIK is *only* the Central Line on a Mac Smile

Cheers

Chris Lees

http://www.bvecornwall.co.uk

leezer3

Posts : 747
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by Northern Line on Thu Mar 24, 2016 1:33 am

leezer3 wrote:Other than for testing purposes, please only enable if you need it, which AFAIK is *only* the Central Line on a Mac Smile

Does the Central Line (Latest) work on a Mac? I heard the plugin isn't compatible to run with it otherwise it actually works?

Northern Line

Posts : 273
Join date : 2011-07-12
Age : 23
Location : Tooting, London, England

http://www.bve-district.co.uk/

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by MattD6R on Thu Mar 24, 2016 2:58 am

I haven't see issues with timetable textures because route I have run just have the default timetable. When I been testing my route (unreleased) it often been the same objects which are not animated objects. I get this with BWR 2015 "Ballyfeckin-Ballinamo 1A" route file and NWM "2006-2010 era\07.10 [323] Maybank-Riverside3car local". With that NWM route a large number of textures are affected. I have only used this option for testing.

Also I also mention that when testing the above NWM route that the program was stuck on loading at 78% and was fine I tried it again. The crash log is as the following:

24/03/2016 12:48:05 PM
OpenBVE 1.4.55.1003-travis Crash Log
Program is running on the Windows backend
Current screen resolution is: Windowed 900px X 600px
Current routefile is: C:\openbve\openbve Route and Train Content\Railway\Route\Network West Midlands 2014\2006-2010 era\07.10 [323] Maybank-Riverside3car local.csv
Current train is: C:\openbve\openbve Route and Train Content\Train\Cl323 3 car Refurb London Midland
The current routefile caused the following exception:
Failed to swap buffers for context 65537 current. Error: 6
Current program memory usage: 111.96mb
System memory free: 4987mb

MattD6R

Posts : 212
Join date : 2013-06-16
Location : Brisbane, Australia

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by atimur on Thu Mar 24, 2016 5:40 pm

I tested 1.4.29.1110 and it crashes on startup with

I tested on Brazilian Line 11 route, it has lots of big textures and animation. Btw I can make Russian translation  Smile

atimur

Posts : 19
Join date : 2014-09-21

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by leezer3 on Fri Mar 25, 2016 10:29 am

This one?
http://superbvebrasil.blogspot.co.uk/2012/12/linha-11-coral-v2.html?m=1

Will take a look later, probably my fault!

Cheers

Chris Lees

http://www.bvecornwall.co.uk

leezer3

Posts : 747
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by leezer3 on Fri Mar 25, 2016 12:14 pm

No crashes here Sad
Are you sure you're on the most recent nightly build, as that build number is rather old?

http://vps.bvecornwall.co.uk/OpenBVE/Builds

Should be OpenBVE-2016-03-24.tar.gz
Build number should be 1.4.56.830-travis

If no luck, please open the UserData\Settings\ folder, and see if there are any crash log files- Post the most recent here.
(Note: On a default Windows install, you'll find this folder under C:\Users\**Your UserName**\AppData\Roaming\openBVE\UserData\Settings\)

Cheers

Chris Lees

http://www.bvecornwall.co.uk


Last edited by leezer3 on Fri Mar 25, 2016 10:38 pm; edited 1 time in total

leezer3

Posts : 747
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by atimur on Fri Mar 25, 2016 4:28 pm

leezer3 wrote:No crashes here Sad
Are you sure you're on the most recent nightly build, as that build number is rather old?

Should be OpenBVE-2016-03-24.tar.gz
Build number should be 1.4.56.830-travis

If no luck, please open the UserData\Settings\ folder, and see if there are any crash log files- Post the most recent here.
(Note: On a default Windows install, you'll find this folder under C:\Users\**Your UserName**\AppData\Roaming\openBVE\UserData\Settings\)

Cheers

Chris Lees

http://www.bvecornwall.co.uk
Aw right, thanks  Very Happy  sorry for (probably?) false alarm, I just needed to scroll several pages to find the latest version and probably missed the link. Will test it and reply at once Smile

Uhm... link to bve gives error 404


Last edited by leezer3 on Fri Mar 25, 2016 10:39 pm; edited 1 time in total (Reason for editing : Dud link removed from quoted post :))

atimur

Posts : 19
Join date : 2014-09-21

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by leezer3 on Fri Mar 25, 2016 9:18 pm

Trying again.....
http://vps.bvecornwall.co.uk/OpenBVE/Builds

leezer3

Posts : 747
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by leyland1195 on Sat Mar 26, 2016 10:52 am

Hi Leezer3

I just downloaded the latest version which is a .tar.gz and put the files into a folder in my OpenBve folder and tried running Openbve and it came up with these errors:




So i thought i would try the 2nd latest version on page 13 which is a .7Zip file and put them into a folder in my main Openbve folder and it worked perfectly so deleted the files and put the latest one in and it came up with these errors again Sad so not sure whats wrong probably something really simple my end i am not doing

Kind regards

Leyland1195

leyland1195

Posts : 2
Join date : 2012-09-24

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by leezer3 on Sat Mar 26, 2016 12:05 pm

Oversight Sad
Won't go into the technical details, but in the openBVE folder, there is a file named 'openBVE.exe.config'

Open this file with a text editor (Notepad etc.), and edit it's contents to the following:
Code:
<?xml version="1.0" encoding="utf-8"?>
<configuration>
<startup><supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0"/></startup>
<runtime><loadFromRemoteSources enabled="true"/></runtime>
</configuration>

That will fix that one.
I've also added the fix to the main source, so any builds with today's date or newer should be OK.

Cheers

Chris Lees

http://www.bvecornwall.co.uk

leezer3

Posts : 747
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by leezer3 on Sat Mar 26, 2016 1:55 pm

OK, so I've now found (I think....) the absolute root cause of the 'Unload Unused Textures' bug, and it's a little technical Smile

Matt (You can reproduce easily!)-
Please can you try running with the following options:

  • Unload Unused Textures==> On
  • Disable OpenGL Display Lists==> On


I *think* that should now work without creating any white textures, but I'd appreciate confirmation before I set the options to work in that way.

A more technical explanation:
For certain types of static objects, openBVE can use OpenGL display lists in order to speed up rendering a little. These are created once when an object is shown.
Essentially they create a single batched set of geometry, which is calculated once, and then uploaded to the graphics card multiple times whilst the object is visible on-screen.
The existance of the textures in graphics memory is checked once when the batch is created, and not again, as they are then assumed to be present.

The current way 'Unload Unused Textures' works is to check the last access of the textures in openBVE's internal texture array, rather than in graphics memory.
Hence, it is currently possible for a texture to be accessed whilst in the graphics memory, but for this not to update the last access time Smile

Cheers

Chris Lees

http://www.bvecornwall.co.uk

leezer3

Posts : 747
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by MattD6R on Sun Mar 27, 2016 12:59 am

With those options all textures are displayed correctly with none shown as white. Smile

MattD6R

Posts : 212
Join date : 2013-06-16
Location : Brisbane, Australia

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by atimur on Mon Mar 28, 2016 6:22 pm

leezer3 wrote:Trying again.....
http://vps.bvecornwall.co.uk/OpenBVE/Builds
Now works, thanks! Will test it and say what I get...

atimur

Posts : 19
Join date : 2014-09-21

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by atimur on Mon Mar 28, 2016 6:34 pm

It works without problems (I used 2016-03-27 folder) in fullscreen mode. Also looked if that texture issue with objects like fences appear and it seems okay too. Good job! Very Happy I'm going to try bogie turn functions too soon

atimur

Posts : 19
Join date : 2014-09-21

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by leezer3 on Mon Mar 28, 2016 10:59 pm

atimur wrote:It works without problems (I used 2016-03-27 folder) in fullscreen mode. Also looked if that texture issue with objects like fences appear and it seems okay too. Good job! Very Happy I'm going to try bogie turn functions too soon

'Proper' bogie turn functions are not yet complete, or in the current download Smile
If you want to test them, you'll need to compile a copy of the branch 'BogieMotion' yourself.

Will let everyone know when they appear properly.

Cheers

Chris Lees

http://www.bvecornwall.co.uk

leezer3

Posts : 747
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by leezer3 on Fri Apr 01, 2016 12:10 pm

Note: This topic has been moved to the 'Sim In Time' section of the board, and a couple of stickies created Smile

Please use this board for discussion of the current situation/ new development builds!

I'll leave this thread running for the moment, but I will try and create a new thread whenever a build with significant new features is created.

Cheers

Chris Lees

http://www.bvecornwall.co.uk

leezer3

Posts : 747
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by atimur on Fri Apr 01, 2016 6:29 pm

(sorry in advance if I'm writing in a wrong place)
I did some research and it turns out that bogie animated file (i.e. its frame and rotating axles) can't be attached into another .animated file of a car, it can take b3d/csv only, so if you write, for example:
Code:
[object]
States = bogie.animated
RotateYfunction = CurveRadius * 0.01
it'll throw an error and won't show models properly.
(Though I might be wrong about the latest build, I tested that on 1.4.5 by joeyfoo). Is it possible to implement "animated-in-animated" structure?

atimur

Posts : 19
Join date : 2014-09-21

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by leezer3 on Sat Apr 02, 2016 12:56 am

Joeyfoo's builds won't recognise the CurveRadius statement- That requires one of my nightlies Smile

Animated files within animated files will also not work at present.
No real intentions of changing this at the moment- Requires a *lot* of complicated 3D maths to get right.

Cheers

Chris Lees

http://www.bvecornwall.co.uk

leezer3

Posts : 747
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by Dj Hammers on Wed Apr 06, 2016 3:26 pm

Out of curiosity, will there be any compression of add-on packages created by openBVE? This would ensure that download times are not excessively long.

Dj Hammers

Posts : 80
Join date : 2012-05-08
Age : 20
Location : United States

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by leezer3 on Wed Apr 06, 2016 9:59 pm

Compression for packages created is zip (LZMA).
Not quite as good as is possible, but not bad at all.

It will (Should.....!) alternatively be possible to just add an appropriately formatted XML descriptor file to any existing archive and the extractor plugin to handle it.
Biggest problem at the minute is turning out to be file selection for adding to packages, as this is actually much more complicated than it looks!


Project name discussion split here:
http://bveworldwide.unlimitedboard.com/t1267-project-name-etc

Cheers

Chris Lees

http://www.bvecornwall.co.uk

leezer3

Posts : 747
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by Greater Anglia Metro on Mon Apr 11, 2016 6:58 am

Feature request: Animated objects that can play sounds? Smile


Greater Anglia Metro

Posts : 107
Join date : 2012-03-24
Age : 23
Location : London

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by Dj Hammers on Wed Apr 13, 2016 3:05 pm

leezer3 wrote:Compression for packages created is zip (LZMA).
Not quite as good as is possible, but not bad at all.

It will (Should.....!) alternatively be possible to just add an appropriately formatted XML descriptor file to any existing archive and the extractor plugin to handle it.
Biggest problem at the minute is turning out to be file selection for adding to packages, as this is actually much more complicated than it looks!


Project name discussion split here:
http://bveworldwide.unlimitedboard.com/t1267-project-name-etc

Cheers

Chris Lees

http://www.bvecornwall.co.uk
Thank you for the information!!! This feature would truly revolutionize the simulator, making it MUCH easier to install add-on content. The #1 issue I hear from people regarding program usage BY FAR is difficulties installing add-ons. Do you have an estimate on when this feature will be implemented?

Dj Hammers

Posts : 80
Join date : 2012-05-08
Age : 20
Location : United States

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by leezer3 on Wed Apr 13, 2016 5:19 pm

Dj hammers wrote:Thank you for the information!!! This feature would truly revolutionize the simulator, making it MUCH easier to install add-on content. The #1 issue I hear from people regarding program usage BY FAR is difficulties installing add-ons. Do you have an estimate on when this feature will be implemented?
No, sorry Smile

OK, so a few details on what actually is and isn't working at the minute:
Working:

  • Package creation.
  • Package install.
  • Package uninstall.
  • UI is *mostly* complete, but has a lot of issues to sort out.


Not Working:

  • The basic framework for dependencies & recommendations is in place, but a lot of the UI is either incomplete or doesn't work perfectly.
  • Adding files to a package is surprisingly hard- The route parser doesn't store a list of files anywhere, and this isn't really that helpful either, as different routefiles might want different objects. I've mostly been using a fixed path for testing purposes. 
  • Extracting 'legacy' files- It's easy enough to detect an archive's contents and place them in the appropriate folder, but I haven't got that far yet- Sorry!
  • Anything not mentioned as working Razz 



The Github branch I've been developing this on is https://github.com/leezer3/OpenBVE/tree/PackageInstaller
I will also note that I've done 100% of my testing so-far on Windows. Things *should* translate to other operating systems, but until I've finished and tested this I make no promises.

Cheers

Chris Lees

http://www.bvecornwall.co.uk

leezer3

Posts : 747
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by Dj Hammers on Sun Apr 17, 2016 8:52 am

Just tried the newest build on Mac OS. Same settings as before with a route/train combo that worked before as well. Program crashes when loading route. Crash logs attached.
Attachments
openBVEMacCrash.zip You don't have permission to download attachments.(27 Kb) Downloaded 3 times

Dj Hammers

Posts : 80
Join date : 2012-05-08
Age : 20
Location : United States

Back to top Go down

Re: New OpenBVE Build- Testers Please

Post by Sponsored content Today at 2:30 pm


Sponsored content


Back to top Go down

Page 14 of 17 Previous  1 ... 8 ... 13, 14, 15, 16, 17  Next

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum